Tesla Owners Online Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter · #1 ·
As soon as I hit D, the screen showed the image of a key card being placed on center console. I checked my Android, Bluetooth on, app good. I re-paired phone. Solved the problem'
Next day, same thing. And again.
Any advice?
 

·
re member
Joined
·
806 Posts
Is it in your pants pocket away from the center console (or right mirror?)?

Bluetooth has difficulty with water and our bodies are mostly water so leg may block it. Raise the phone/leg while twisting your body a tad and it’ll work. I’m not sure why you have two minutes to drive away if you unlock with the keycard but have to keep the BT connected device in line with the antenna.

If that’s not the case, could be an antenna issue (either the phone or the car). I had a hairline break in my phone’s BT antenna which would intermittently fail to start car (and, on iPhone, also impacted gps reliability) but never kept me from opening the car door.
 

·
Registered
Joined
·
127 Posts
Discussion Starter · #4 ·
I've been having this issue a lot recently with the latest 2022.12.* versions of software.

I'm assuming that it's just another software bug, and that Tesla will hopefully get around to fixing it at some point.
Yes Garsh...we have never had any problems until recently..about the time of the 2022.12.
I had an appointment with the Tesla center in Portland,Or. for a fix on our hardly working windshield spray system and was planning to ask them about the key card/phone problem tommorow. Just got a message they do not have parts. Oy. O well, am waiting to hear if the Mobil guy can fix both..when ever that happens...
 

·
Registered
Joined
·
229 Posts
As soon as I hit D, the screen showed the image of a key card being placed on center console. I checked my Android, Bluetooth on, app good. I re-paired phone. Solved the problem'
Next day, same thing. And again.
Any advice?
Another thing I find is that there is not a quick change over from wifi to bluetooth when at home. I find when on bluetooth only there is not a problem with this, but coming off a wifi connection going to car away from strong wifi the bluetooth doesn't kick in quickly.
I have to activate my app to get car to activate in those cases.
 

·
Super Moderator
Joined
·
16,723 Posts
I've posted about this in the 2022.12.* software thread, in case others have encountered this but haven't discovered this thread yet.

I've been having issues with phone-as-key in this series of software.

Interestingly, when the car has been asleep in my garage overnight, I have no issues. The Tesla App notification says that it's "Connected", and I'm able to jump in and drive.

But after it's been sitting at work all day with sentry mode on, I have issues. The Tesla App says "Disconnected", even after I bring the app to the foreground on my phone. The car doesn't recognize the phone to allow me to open the door.

As a workaround, I've used the app to unlock the car remotely, and that works. But the car still doesn't recognize the phone, and instructs me to use a keycard when I try to put it in drive. Again, as a workaround, I've been using the remote "Start" button in the app, and that works.

I've got a fairly top-of-the-line phone (Google Pixel 6), so I doubt it's a phone issue. And this series of software has had several other bad regressions (backup camera stuttering and dashcam failures), so I feel safe blaming the car software.
 

·
Super Moderator
Joined
·
16,723 Posts
Hmm... I wonder if this might be related to the dashcam issues?

Maybe tomorrow I'll try removing my USB drive from the car while I'm parked at work and see if I still have this issue when I go to leave work.
 

·
Registered
Joined
·
3 Posts

·
Registered
Joined
·
225 Posts
Mine has been doing this as well since the last update. If my phone is in my left pocket, I have to take it out of my pocket for the car to see it. Almost as if the "range" is less.
 

·
Super Moderator
Joined
·
16,723 Posts
A new datapoint:

Yesterday I parked my car at work. It was charging the entire time. But since I had arrived with <20% SOC, Sentry Mode didn't turn on.

When I approached the car to leave, I had no issues! The app connected, and it unlocked the door for me when I pressed on the door handle.

So, this appears to be associated with either Sentry Mode or the USB drive. Today, I parked (without charging) and manually disabled Sentry Mode. I expect to have the same results as yesterday, but I'll confirm that.

Tomorrow I'll try to leave Sentry Mode enabled, but remove the USB drive. I would imagine that this will avoid the issue as well, but I'd like to confirm.
 

·
Super Moderator
Joined
·
16,723 Posts
Maybe tomorrow I'll try removing my USB drive from the car while I'm parked at work and see if I still have this issue when I go to leave work.
I actually removed the USB drive this morning, but I had forgotten that the car had updated to 2022.16.1.1 last night. So I'll have to see if I still have these phone-as-key issues with this new build.
 

·
Premium Member
Joined
·
253 Posts
Happy I found this. I too have been having this exact issue off-and-on since updating to 10.12.2. I now can rest easily knowing that it's nothing I did, but happening all over. I'd hate to be that guy (or gal) that left their keycard home when they discovered this... I'm sure there's more than one.
 

·
Premium Member
Joined
·
253 Posts
Restating what has already been stated before, if you don't have your keycard, you can still 'start' the car from the app.
 
  • Like
Reactions: garsh

·
Registered
Joined
·
734 Posts
Another data point. Samsung S21+.
With Sentry off in my garage, no problem.

But Sentry was on today on various trips and after failing yesterday, the BT lock and car start worked perfectly. I expected it to fail but it didn't. I am still on 2022.12.3.20

BTW, even with the BT lock failing, on my phone the NFC key continues to work. So no need for the key card or app to launch to start the car.
 

·
Registered
Joined
·
127 Posts
Discussion Starter · #17 ·
Still doing the same thing. We reinstalled the Tesla app, up dated. Bluetooh working. Screen looked normal, put car in D and the screen asked for the Tesla black card to be placed on the center console. Got out of car, walked away 10', then back in the car. Again, asked for key card.This time when I hit D, the car engaged. Getting very tired of this.
 

·
Super Moderator
Joined
·
16,723 Posts
Still doing the same thing. We reinstalled the Tesla app, up dated. Bluetooh working.
This bug is specific to version 2012.12.* of the vehicle software. It's not the app's fault.

You can prevent this bug from occurring by either turning Sentry Mode off, or unplugging the USB drive that you use for Sentry Mode.

You can work around the bug either by using a keycard, or by using the app controls to first Unlock, then Remote Start the car.
 

·
Registered
Joined
·
225 Posts
When it happens to me, my range...I am sitting in the drivers seat.
Same for me. It recognizes the phone to enter the car, but sitting in the driver's seat it doesn't see the phone if it's in my left pocket. I have to take it out and move it closer to the console.
 
1 - 20 of 22 Posts
Top